
1 

 
 
 

Canlan Ethernet 
Controller 

 
 

Troubleshooting Guide 
 
 

 
 



2 

 

Contents 
 

 
Introduction ......................................................................................................................... 3 
Requirements ...................................................................................................................... 4 
Troubleshooting Strategies ................................................................................................. 5 
Problem Classification ........................................................................................................ 6 

Network Connectivity ..................................................................................................... 6 
Serial Connectivity.......................................................................................................... 6 
Configuration Errors ....................................................................................................... 6 

Network Connectivity ......................................................................................................... 7 
Maestro ........................................................................................................................... 7 
Maestro continued ........................................................................................................... 8 
Maestro continued ........................................................................................................... 9 
Smartlock Pro................................................................................................................ 10 
Smartlock Pro continued ............................................................................................... 11 
Smartlock Connect ........................................................................................................ 12 
Zodiac Max ................................................................................................................... 13 

Serial Connectivity............................................................................................................ 14 
Maestro ......................................................................................................................... 14 
Maestro continued ......................................................................................................... 15 
Smartlock Pro................................................................................................................ 16 
Smartlock Connect ........................................................................................................ 17 
Zodiac Max ................................................................................................................... 18 

Advanced Diagnostics ...................................................................................................... 19 
User Interface ................................................................................................................ 19 
Establishing a Connection............................................................................................. 20 
Querying Information ................................................................................................... 21 
Querying Information continued ................................................................................... 22 
Diagnostics .................................................................................................................... 22 
Diagnostics continued ................................................................................................... 23 
Remote Reset ................................................................................................................ 24 

 
 



3 

 

1 Introduction 
 

The adoption of IP capable security devices is now very much the norm as 
they leverage existing structured cabling systems reducing installation and 
maintenance costs. These benefits come at certain expense. Installing 
and maintaining a TCP/IP based security system requires networking 
skills and knowledge to accurately identify, diagnose and correct the 
problem. Furthermore, the network over which the system is running 
usually is outside the immediate control of the service technicians called in 
to effect repairs. If a network fault or configuration error is suspected, it is 
critical that the technician is able to quickly and accurately express the 
symptom(s) and concerns in a language that Network Management staff 
understands.  
 
Nonetheless, it is the belief of the author that a deep understanding of the 
internals of TCP/IP or networking in general is not a requirement for 
effectively troubleshooting and resolving most Canlan issues. A more 
general understanding of networking coupled with an innate sense for 
information gathering and deduction will prove sufficient for most 
installations, Enterprise scale or otherwise. 
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2 Requirements 
 

This troubleshooting guide is based on the new diagnostic features 
available in the Canlan beginning with Version 7. Many of these features 
have been requested by installers, technicians as well as our own tech 
support staff. While these new diagnostics will aid in the troubleshooting 
process, some basic equipment is a must for analyzing and isolating the 
relevant data. 
 
The following set of basic tools will prove invaluable when isolating the 
cause behind connectivity and operational issues.; 

 
 A laptop computer with Ethernet interface 
 An inexpensive 4 port hub  
 A selection of straight and crossed Cat5 patch cables 
 A USB to serial interface in the event the laptop does not have a 

serial port. 
 A Cla50 or USB to RS485 interface for direct testing of controllers 
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3 Troubleshooting Strategies 
 

As most of you know, trouble shooting follows the same basic strategies 
regardless of whether it’s a plumbing, home stereo, or network based 
security system problem. There is usually a degree of sleuthing involved 
so the more facts you have on hand, the greater the likelihood of a quick 
resolution to the problem. Some typical questions one might ask ones self 
prior to jumping in are; 
 

• What works? 
• What does not work? 
• How are the things that do and do not work related? 
• Have the things that do not work ever worked? 
• If so, what has changed since it last worked? 

 
In many cases an experimental approach using the scientific method is an 
appropriate place to begin. The scientific method is best summarized as 
follows; 
 

1. Observation. 
2. Formulate an hypothesis (an educated guess) 
3. Predict a unique consequence of that hypothesis 
4. Test the prediction by experiment 
5. If test fails, go back to step #2. If test passes, hypothesis is 

provisionally confirmed. 
 
This methodology is very useful in technical troubleshooting, since 
troubleshooting is fundamentally a determination of cause for an observed 
effect. Other useful strategies to be considered are fault isolation through 
a process of elimination, or similarly reducing the number of potential 
variables through a divide and conquer method. Swapping of component 
devices is a powerful and easy test where appropriate and available. 
 
In the next section we will attempt to classify the types problems one 
might encounter with a Canlan is the field and leverage this fault 
identification by focusing our attention on the more likely candidates.
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4 Problem Classification 
 

Almost invariably, the symptoms of a problematic Canlan resemble a 
connectivity issue of some sort. It is helpful to classify which of the two 
types of connection problems are being experienced as this will direct 
further efforts. It is important to note, that a third class of errors,  
Configuration Errors, may be the root cause. These more subtle 
conditions can masquerade as connectivity problems, or defective 
hardware.. 
 

 Network Connectivity 
 

This will be either a TCP/IP or Ethernet connection problem in which the 
host software experiences constant or intermittent troubles establishing a 
connection with the Canlan. The symptoms vary by product type and may 
appear to indicate faults on the serial interface side or with the actual 
access control device as opposed to the Canlan. 
 

 

Serial Connectivity 
 

Serial connection problems are defined by transmission and/or reception 
errors over the RS232 or RS485 interface. Again the symptoms are 
product type dependant, but generally appear in the form of no 
communication messages. 
 

 

Configuration Errors 
 

This broad class encompasses not only the Canlan’s configuration, but 
potentially intermediary devices involved in the communication path such 
as firewalls, routers, switches or the actual access control units 
themselves. A list of potential areas where incorrect device configuration 
may be responsible will be discussed in an upcoming chapter. 
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5 Network Connectivity 
 

 
A Canlan acts as a TCP server accepting connections on a user 
configurable TCP/IP port number for Cansec access control software and 
telnet port 23 for diagnostic purposes. The default access control software 
port is 5000. Network connectivity issues involve failures by the access 
control software to establish a connection to the respective access control 
TCP port.  
 
Definitive symptoms of connectivity issues between host software and a 
Canlan are as follows; 
 

 

Maestro 
 

Maestro versions 4.2 R3 or later report Canlan connection problems via 
two event messages; displayed in the transaction view window and 
recorded in the audit logs; 
 

 
 
The <Time Date> field identifies when the event occurred while the <Trunk 
Name> and <IP Address:Port> fields indicate which Maestro Canlan trunk 
and its associated IP address information. The Network Connection Lost 
message indicates an inability for the Maestro host software to establish a 
socket connection with Canlan. The IP address information specifies the 
address and port number Maestro used while trying to initiate the 
connection. The Network Connection Restored message signals that a 
connection has been established with a previously un-connectable 
Canlan. 
 
Versions of Maestro prior to the V4.2 R3 release do not provide a unique 
event message for Canlan connections failures. If a connection can not be 
established in these earlier versions, Maestro publishes a No 
Communications message for each control panel on the associated 
Canlan device. 
 
Since Canlan connection failures appear more like controller 
communication errors, the following alternate sources provide more 
definitive information regarding Canlan connection states. 

<Time Date> Network Connection Lost  <Trunk Name> <IP Address:Port> 
<Time Date>  Network Connection Restored <Trunk Name> <IP Address:Port> 
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Maestro continued 
 

Communication Statistics Window 
The Communications statistics window is available from the View > 
Communications menu and provides current Canlan connection 
information. 
 
 Trunk selection is 
made from the drop 
list at the bottom of 
the window where 
Canlan trunks in the 
range 17 through 255, 
may be chosen for 
display. In the 
example below (Trunk 
17), Maestro has an 
active connection with 
the Canlan at address 
10.0.0.72, port 5000. 
 

 
 
 
 
 
In the this next 
example (Trunk 18), 
Maestro can not 
establish a connection 
with 10.0.0.7, port 
5000 as indicated by 
the Offline status and 
red led icon. 
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Maestro continued 
 
System Logs 
An additional record of Canlan connectivity problems are the log files 
maintained by the Maestro server and standalone software. The file 
“server.log” records connection failures and Canlan controllers which do 
not respond to the periodic heartbeat supervisory packets sent by 
Maestro. 
 
 

 
 
In the example above, a socket connection could not be established with 
the Canlan at address 10.0.0.7, port 5000. 
 

MaeSrvr, 07-09-07 10:34:24 Line 655, D:\Src\Maestro\WinPm\COMMENG\Mss.c 
SockOpen failed while connecting to 10.0.0.7:5000 



10 

 

Smartlock Pro 
 

The Smartlock Pro does not explicitly annunciate Canlan connection 
errors in its Event View display. Network and serial interface errors are 
reported using the generic event message; 
 

 
 
 

Pro controllers connected via a 
Canlan are defined by setting 
the Connection type to Network 
when the controller is defined 
and entering the associated 
Canlan IP address. When 
troubleshooting a Canlan 
network connection, we must 
know the address and/or name 
of at least one of the associated 
Pro controllers which are 
connected to its serial interface.  

 
 
This is information that will be required when viewing the Communications 
window and examining the network status. Select the View > Statistics 
menu item to call up the Communications window. 

<Time Date> Communication Failure <Reader Name> 
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Smartlock Pro continued 
 

 

 
 
The Unit and Name columns identify the controller address and name 
respectively. The Network column indicates if the controller is connected 
via a Canlan or not. An entry of Yes denotes a Canlan connected Pro 
controller, while a No entry a hardwired RS485 connection. 
 
The current host to Canlan connection state is shown in the Net Status 
column. The following states are possible; 
 

 Connected: an active host/Canlan connection has bee 
established 

 Connecting: the host is in the process of establishing a 
connection. 

 Disconnected: the host has not be able to establish a 
connection and will attempt again momentarily. 

 
Ideally, all Pro controllers marked as Network connections will have the 
Connected state in this display window. Those who don’t are currently 
offline and experiencing some sort of network difficulty or hardware fault. 
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Smartlock Connect 
 

The Connect software unlike Maestro and Smartlock Pro communicates 
with its associated Pro controllers only in response to operator commands 
such as download, upload, etc. Consequently, Canlan connection issues 
are observed only during the initial connection phase. 
 

Controllers that are accessed through 
Canlan or modem interfaces are the 
only devices which display this popup 
box. 

 
If a connection can not be established with the Canlan, the Connect 
software reports the following error message box and terminates further 
communication attempts. 
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Zodiac Max 

 
The Zodiac Max software and controllers communicate infrequently 
primarily in response to fingerprint enrollment and data downloads. 
Additionally, the Max software sends a status poll on a programmable 
interval to test availability. Max software records communication events in 
its system log in the following format; 
 

 
 
These log messages can give a rough idea of the communications history, 
but they do not identify specifically the type of error which has occurred. 
Tests run using the Canlan diagnostic software will be necessary to get a 
more definitive view of communication problems. 

A communications timeout has occurred, Controller Address n  (IP Address/Serial) 
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6 Serial Connectivity 
 

The second role of the Canlan controller is to provide RS232 and RS485 
serial communication services to the host software. In the case of a 
Maestro system, the Canlan implements the CP40 host serial protocol in 
firmware and manages this side of the interface independently of Maestro 
decreasing bandwidth usage and removing the processing requirement 
from the Maestro host machine. 
 
Serial connectivity errors arise when the target device does not respond to 
transmission made by the Canlan controller. This may be an intermittent 
or permanent condition affected by a number of variables. In this chapter 
will examine the symptoms of serial communication errors from the host 
software perspective. 
 

 
Maestro 

 
Maestro reports CP40 connection problems via two event messages; 
displayed in the transaction view window and recorded in the audit logs; 
 

 
 
The <Time Date> field identifies when the event occurred while the <Panel 
x, Trunk y> fields indicate the panels address and trunk number. The No 
Communications message occurs after 3 successive attempts to poll the 
panel went unanswered.  The Communications Restored message signals 
that a response was received from a panel that previous was not 
responding to status polls. 
 
Versions of Maestro prior to the V4.2 R3 release do not provide a unique 
event message for Canlan connections failures. If a connection can not be 
established in these earlier versions, Maestro publishes a No 
Communications message for each control panel on the associated 
Canlan device. Consequently, for these earlier Maestro versions, the 
Communications statistics window should be consulted for appropriate 
trunk. 
 
 

 

<Time Date> No Communications  <Panel x, Trunk y> 
<Time Date>  Communications Restored  <Panel x, Trunk y> 
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Maestro continued 
 

Communication Statistics Window 
The Communications statistics window is available from the View > 
Communications menu and provides current Canlan connection 
information. 
 

  
 
Trunk selection is made from the drop list at the bottom of the window 
where Canlan trunks in the range 17 through 255, may be chosen for 
display. In the example below (Trunk 17), Maestro has an active 
connection with the Canlan at address 10.0.0.72, port 5000. 
 
The Timeouts column keeps a count of the number No Communication 
messages received from the Canlan and is thus a good indicator of which 
panels are experiencing problems and to what degree. The sent column is 
count of the number of commands sent to a panel via the Canlan, while 
the remaining columns are not applicable to a Canlan based trunk. This 
information can be retrieved by using the Advanced Diagnostics software. 
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Smartlock Pro 
 

The Communications window is the best place to start to examine any 
type of communication issue with a Pro controller, serial or network. Select 
the View > Statistics menu item to call up the Communications window. 
 
 

 
 
The Unit and Name columns identify the controller address and name 
respectively. The Network column indicates if the controller is connected 
via a Canlan or not. An entry of Yes denotes a Canlan connected Pro 
controller, while a No entry a hardwired RS485 connection. 
 
The Offline column indicates whether the controller is currently considered 
offline by the Pro software. This occurs after three consecutive polls are 
sent without a response from the controller. The Polls column counts the 
total number of polls sent to a controller, while the Timeouts column 
counts the total number of polls for which no response was received. 
These values should be interpreted relative to one another. For example 
100 timeouts for 1000 polls sent represents a 10% failure rate by the 
controller and may be cause for concern. On the other hand 100 timeouts 
for 100,000 polls sent represents a 0.1% failure rate and is relatively 
inconsequential and not cause for much concern. 
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Smartlock Connect 

 
The Smartlock Connect communicates on an as required basis and as 
such must connectivity must be explicitly tested. The simplest way to 
perform this test is to simply double click a reader icon from the Reader 
View. This will result in a status poll be sent and the current reader status 
data displayed. An unresponsive controller will not respond to the poll and 
the status display will indicate the communication failure. 
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Zodiac Max 

 
As mentioned previously, the Zodiac Max software and controllers 
communicate infrequently. Max software records communication events in 
its system log in the following format; 
 

 
 
These log messages can give a rough idea of the communications history, 
but they do not identify specifically the type of error which has occurred. 
Tests run using the Canlan diagnostic software will be necessary to get a 
more definitive view of communication problems. 

A communications timeout has occurred, Controller Address n  (IP Address/Serial) 
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6 Advanced Diagnostics 
 

The Canlan version 7 firmware release adds several new diagnostic 
features which are accessible from new diagnostic software 
accompanying the release. The Canlan Advanced Diagnostics provides 
the following new troubleshooting features. 
 

 Query functions including host  connection status with IP and port 
number, detailed communication error statistics, flash configuration 
and firmware information. 

 Integrated controller serial communication tests. 
 Remote reset and auto configuration software launch. 
 Password protected diagnostic network interface. 

 
The new diagnostics software interface continues to provide the system 
trace log functionality provided by the current Canlan Diagnostics 
software, but adds the feature set above and a new user interface. This 
chapter will discuss the Advanced Diagnostics software and its new 
interface. 
 

 
User Interface 

 
The Advanced Diagnostics software employs a simply user interface 
consisting of standard menu, toolbar and client display areas. 
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The main client area of the window display Canlan diagnostic trace and 
query data as it is received from the controller Ethernet. The first column 
designated as Up Time displays the elapsed time since the Canlan was 
reset. This information when present indicates that this text originates from 
the Canlan. If not present, the text originates from the diagnostics software 
itself. The second column contains data associated with an ongoing trace 
session or responses to operator initiated queries.  
 

 
Establishing a Connection 

 
Diagnostic connections can initiated from the File > Connect menu or the 
Connect toolbar button. 
 

 
 
The Connect dialog is displayed and the associated IP address and 
optional connection password must be entered. 
 

 
 
Pressing the OK button initiates the connection and if successful the logon 
banner is displayed. 
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Querying Information 

 
The Query menu items supply relevant configuration and 
connection/communication information regarding system operation.  
 

 
 

 
 

 
 
The Firmware revision query is available from the Query > Firmware Revision menu 
item or the Firmware toolbar button below. 
 

 
 
This query reports the firmware revision and the current flash memory configuration 
as shown below. 
 

 
 

 
 
The Connection Status query returns information regarding the currently 
connected host system (if any). This query command is available from the Query > 
Connection Status menu item or the Connection Status toolbar item. 
 

 
 
Information regarding the connection state includes the host IP address and port 
when connected 
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Querying Information continued 
 

 
 

 
Diagnostics 

 
The Diagnostics menu contains commands for controlling real time trace 
logging and serial communications tests from the Canlan. 
 

  
 

 
 
The Communications Statistics query returns details regarding the serial 
communications between the Canlan and associated control units. This information 
varies depending on the operational mode. This query is accessible via the Query > 
Communication Statistics menu item or the Communication Statistics toolbar button. 
 

 
 
Statistics for a Smartlock Pro interface are shown in the example below. 
 

 
 

 
 
The Canlan can be instructed to output diagnostic information in real time using 
three selectable detail levels. The trace level can be selected from the Diagnostics 
> Set Trace Detail Level menu item or from the toolbar button below. 
 

 
 
Low detail level logs major events such as host connection/disconnection, controller 
communication errors etc. At the lowest level, all aspects of operations are output 
including each serial transmission and reception. 
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Diagnostics continued 

 

  

 
 
The Canlan can be commanded to transmit enquiry polls to a definable controller 
address for the purposes of testing the serial interface. Select the Diagnostics > 
Serial Communications Test menu item or the toolbar button below 
 

 
 
The communications test window is displayed and an address may be entered to 
specify the target controller. The appropriate enquiry poll is sent based on the 
Canlan operational mode.  
 

 
 
Press the Send button to transmit an enquiry poll to the selected controller. If the 
poll is successful, the received data is displayed in the main window. If a response 
ti the poll was not received, an error message is shown. 
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Remote Reset 

 
The Canlan can be commanded to perform a soft reset through the 
Advanced Diagnostic software. Select the File > Canlan Soft Reset menu 
item to invoke the reset dialog shown below. 
 
One of the primary reasons for 
performing a reset will be to 
force the Canlan into its initial 
20 second configuration state 
during which time it accepts 
connections from the Canlan 
Configuration software. To this 
end the Launch and connect 
the Configuration software 
checkbox is provided. 
 
Once the reset command has been sent to the Canlan, the Advanced 
Diagnostic program disconnects, waits approximately 5 seconds and then 
launches the Configuration software in an auto-connection mode. The 
Configuration software launches and establishes a connection 
immediately similarly to a connection initiated through the Connect button. 
 


